Number is not showing proper when it is too big


Amount is not showing properly, I concat my amount with currency name.


How can I show it actual?


Hi @ritz
Post "Diagnostic Info" from Admin > Troubleshooting. This will be requested every time you open a topic.
You need to show what you mean by "I concat my amount with currency name".
And how many characters is the amount?

Hi @flamber,

1> "I concat my amount with currency name" means, that column value data type is in string as I concat my amount with currency name.

2> 9 character in my amount.

3> {
"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.99 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.13+8",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "",
"java.version": "11.0.13",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.13+8",
"": "Linux",
"os.version": "4.14.171-105.231.amzn1.x86_64",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "11.12"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.23"
"run-mode": "prod",
"version": {
"date": "2022-01-10",
"tag": "v0.41.6",
"branch": "release-x.41.x",
"hash": "296635f"
"settings": {
"report-timezone": null

@ritz I don't understand what you mean by concat. If you are doing that on the database side, then the problem must be there.




Amount and currency are field in documents.

I combined amount + currency in my custom query and showing it's result in amount column. does it create problem?

@ritz If you are doing this on your database, then I guess the problem is there. You are not providing enough information to understand what exactly you are doing.