Problem with data format in field Filter

I'm getting this message error when I include a specific data field filter:
I think this is happening because the format is not unique, it varies into two formats:
How can I solve this problem?

Hi @Helena
Post "Diagnostic Info" from Admin > Troubleshooting.
If you have data in various formats, then you'll need to fix the data in your database.
Metabase cannot work with random formats (actually most computers cannot handle that).

1 Like

@flamber I've create a view with this format of data:
and i got this message error:
I don't understand what happened :no_mouth:

@Helena You need to fix your data in your database. Try searching the internet for help on how to clean up data in a database, since it has nothing to do with Metabase.

Yes, but this line of code (to_date...) I did on Redshift when creating a new view. So I thought that metabase didn't accept this format of date. Is this right? should I try timestamp format?

@Helena If you can run the exact same query directly on Redshift, then you can also run it in Metabase, since Metabase just send the query to your database.

But I'm sure that you are forgetting to tell about things, so I cannot know what you are doing.

Try providing full context, full screenshots, full queries, and "Diagnostic Info" from Admin > Troubleshooting.

Hi @flamber :slight_smile:
What happened was:

  1. my date column didn't have a unique format, so I couldn't use it as a field filter in matabase;

  2. to solve this, I created a view from the data in the problematic column and converted the dates so that they followed the same format. I ran this code in redshift:

    WHEN SUBSTRING(value, 3, 1) = '/' TO_DATE(TO_DATE(value, 'DD/MM/YYYY'), 'YYYY-MM-DD')
    END AS new_date_colunm

  3. I tried to use this view to use the date field that I fixed, but this error keeps popping up:


Another detail, the format of the date field is in the standard of what I usually use in the metabase:

@Helena Clean up your data and make sure you prevent having such data in the future by using the correct column types.
Check your database query log for the full error. Ask questions in a Redshift specific forum, since I doubt the problem is related to Metabase.