Pulse email timezone

I have the Europe/Moscow timezone on my server and launched metabase with the -Duser.timezone=Europe/Moscow key, but when setting pulse, it shows the MT timezone


tell me how you can fix the MT time zone at Europe / Moscow?

{
  "browser-info": {
    "language": "ru-RU",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.16; rv:82.0) Gecko/20100101 Firefox/82.0",
    "vendor": ""
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "1.8.0_252-8u252-b09-1~deb9u1-b09",
    "java.vendor": "Oracle Corporation",
    "java.vendor.url": "http://java.oracle.com/",
    "java.version": "1.8.0_252",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "25.252-b09",
    "os.name": "Linux",
    "os.version": "4.9.0-9-amd64",
    "user.language": "en",
    "user.timezone": "Europe/Moscow"
  },
  "metabase-info": {
    "databases": [
      "h2",
      "postgres",
      "clickhouse",
      "bigquery"
    ],
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      },
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
      }
    },
    "run-mode": "prod",
    "version": {
      "tag": "v0.37.2",
      "date": "2020-11-16",
      "branch": "release-x.37.x",
      "hash": "25e5f70"
    },
    "settings": {
      "report-timezone": "Europe/Moscow"
    }
  }
}

Hi @garcia
I can reproduce that it shows “MT” instead of some other more correct value, but does it affect when the pulses are sent, or is this just a visual text problem, when creating the pulse?

@flamber thanks for the answer
I would like to receive reports at a certain time in the Europe/Moscow timezone and when clients see the MT time zone, they ask a lot of questions :slightly_smiling_face:
I would like to see the Europe/Moscow timezone

@garcia I understand that. I’m asking if they actually get the reports at the correct time?

@flamber with my setting 8:00 AM MT, notifications arrive at 7:00 AM MSK, i.e. it turns out minus one hour

@garcia Thank you. That was the important part, since that means it’s not just a visual text annoyance, but incorrect use of timezone for the scheduler. I have created an issue for it:
https://github.com/metabase/metabase/issues/13867 - upvote by clicking :+1: on the first post

@flamber Thank you very much, +1 put it, let’s hope that this bug will be fixed soon