Pulse sent to Slack only shows first 20 rows


I just started using Metabase an hour ago, and it looks superb.

I’ve set up a question using some custom SQL, and a Pulse to send it to a slack channel. When I run the Pulse locally, it works just fine…I get a complete and beautiful report. The slack integration also went smoothly, except for a nitpick around saving the pulse, but turning the email on and back off cured that. The Pulse is arriving in the relevant Slack channel as well as the newly-created metabase_files channel, but not all the information is displayed. Vertically, it only shows 20 of 28 rows, and horizontally doesn’t show the bar chart at the right. The 20 rows feels like it might be a limit set somewhere to avoid overwhelming Slack, and the not showing bar charts isn’t that important, but would be nice. IS there a setting somewhere that I can adjust to make this work, and show all rows??

Hi @phands
No, that’s the current limit - as you said, to not overwhelm the recipient.
There’s an issue about having adjustable limits:
https://github.com/metabase/metabase/issues/4564 - upvote by clicking :+1: on the first post

Thanks for clarifying, @flamber at least I can stop looking. I upvoted the issue in Github, but until I can display more than 20 rows, the Slack integration is useless to my company. Shame.