Pulse to Slack doesn't show data


The message (image) received from the pulse always omits data from a specific column. I checked and the column has visibility everywhere.

The only thing I can think of is that the field type is description… implying potentially long text. Is the pulse-Slack API unable to handle long text? (In reality the text is usually just a few lines long).

Any help appreciated!

Hi @Yen
Yes, the Description field type will be removed from pulses, since that type is normally used for longer texts, which isn’t suitable for short things like pulses.
You can set the type to “No special type” (bottom) to include it.

Thanks for this info! Super helpful :slight_smile:

UPDATE: Yikes… sorry @flamber but it seems ever since I changed the field from ‘description’ to no special type, the slack pulse interface just spins… it can’t seem to render a pulse at all anymore (not even one without the text column) and nothing at all is sent to slack. :frowning:

I’m gonna try other types and report back…

Which version of Metabase?
Do you see any errors in the Metabase log, when it’s just spinning? Admin > Troubleshooting > Logs

Found these:

{:message "TypeError: formatter is not a function",
:type jdk.nashorn.internal.runtime.ECMAException,
"--> pulse.color$get_background_color.invokeStatic(color.clj:60)"

Jul 12 18:51:12 ERROR metabase.pulse :: Error sending notification!
<eval>:4306 TypeError: formatter is not a function
at jdk.nashorn.internal.runtime.ECMAErrors.error(ECMAErrors.java:57)

@flamber metabase version v0.32.8. See logs above (or maybe below - sorry - I posted stuff out of order).

Okay, I’m pretty sure you’re hitting this issue (very bad description, scroll down to bottom):
It’s been given Priority 1, but it hasn’t been scheduled for any milestone yet - the team is busy working on the major query browser overhaul in 0.33

So even if you change the type back to Description, it still doesn’t work?
Do you mean that now all pulses are not working or just this single item?

EDIT: Latest release is 0.32.9 (not that I think it will solve your problem, but just noting it)

I’m gonna go back and check if it’s ALL pulses or just this one… I suspect its just this one - i don’t think we’ve impld any other pulses yet). Will report back.

OK as far’s I can see, other pulses work. (pulses without problematic long-form text fields).

@Yen Okay, that’s good. But does the failing pulse start working again if you change field type back to Description?
EDIT: I’m trying to see if I can reproduce your problem, since that will help fixing the issue.

Hi @flamber, yes - the failing pulse starts working again when I change the field back to description - but, per the issue that kicked everything off, the description field itself is never rendered.


@Yen Great! I think we’re on the right track to figuring out what’s going on then.
Can you tell me more about that fields contents:

  • How many characters (how long) is the average, and the longest row?
  • Does contain special characters like new lines?
  • What is the actual database column type of that field?

It is anything that you can type into a slack message. So yes there may be newlines, there MAY be markdown down and emojis but so far I’m not seeing any.

About 75% is a single line comment.
The rest might be a paragraph of text, at most two.


@Yen Okay, I’ve tried multiple different ways to reproduce this without success. I’ve tried to create a varchar(2000) column and populate it with random text and special characters (newline, emoji, etc), but it doesn’t trigger the error. I’ll leave a comment on the issue, and maybe it will help pointing in the right direction.

@flamber if helps, the underlying, origin datatype was postrgresql text. ¯_(ツ)_/¯

@Yen Also tested on Postgres 11.4 with text, but still not able to trigger the error. Not sure what the conditions should be to reproduce the problem.