Repeated tables in custom query builder

I’ve been experiencing some tables that seem duplicated in the list of tables.

The way we are running metabase is:

  • Via Kubernetes
  • Using a Postgres DB for metabase
  • Using a Redshift DB to store all the data for the queries
  • Metabase version 0.28.5

The issue has been appearing in MAC OS and Windows on Chrome.

Any idea?

Are they all tables, or are they views with the same name as the tables? Screenshot would be helpful too.

1 Like

What @AndrewMBaines said + you mention Kubernetes; make sure you don’t run multiple Metabase instances that’s currently not supported (unsure if it could affect that though). There’s a GitHub issue requesting horizontal scaling …

1 Like

Here’s a screenshot.

We have two databases connected to metabase. The biggest (Redshift) is the one showing all the tables duplicated, triplicated or more. In all schemas. The other DB is normal, and quite faster, actually.+

Any ideas? Also the kubernetes factor might impact?

We are experiencing the same problem: we see duplicate listings for some of our tables in the “Select a table” dropdown, for one of our linked databases.

Here’s what we have tried:

  1. We checked our linked postgres database and for views or tables with the same name in another schema. We did not find anything.
  2. We tried going to /admin/databases/1 and hitting “Sync databases now” and “Re-scan field values now”. We also tried using “Discard saved field values”. None of these made a difference, even after multiple attempts.

We have not tried using the “Remove this database” button on /admin/databases/1 because we are concerned that we would lose all of our existing “Questions”.
We have not tried to use psql to investigate the database used by our metabase instance.

Thanks for any guidance on how we might investigate further. :pray: