Returning raw data with no filters always returns We couldn't understand your question

I’ve just found Metabase and am just having a play with it. I’ve connected it to a MySQL DB which is working. However, if I try to ask a new question that just returns the raw data with no filters or grouping then it always returns the message ‘We couldn’t understand your question’.

I then went to the query editor and tried…

SELECT * FROM my_table

This always returns ‘Connection is read-only. Queries leading to data modification are not allowed’ no matter what table I choose.

If I run the same query against the sample data then it returns the data set as expected.

What am I doing wrong? Is this a bug?


Hi Ben,

It's possible you were running into this issue w/ MySQL when the timezone was set, can't use SQL queries on MySQL driver with timezone set · Issue #1291 · metabase/metabase · GitHub

We've since fixed the issue and released a new version of Metabase (v0.13.0), so if you want to upgrade real quick it's very likely this will no longer be an issue.

Works perfect! Thanks!