Set site url from admin panel

I am trying to set the url for my metabase instance on my localhost. Need to provide it to other users. I went to admin panel -> settings -> general -> site url. But when i open the url , it says page doesn’t exists. Also the user’s invite email link also open upto blank page.
What am I missing?

Setting the site url only makes Metabase use that hostname in emails, etc.

However to share an instance of metabase, you need to be on a host that can accept connections from others. Practically, this means using your ip address as the host url unless you can configure DNS to point to it. This is all easiest to do on heroku or elastic beanstalk. Getting people to connect to your localhost is tricky unless you have both a static ip + a stable dns entry.