Snowflake Authentication Failing

I am trying to connect to a Snowflake data warehouse and the connection is failing with error: “net.snowflake.client.jdbc.SnowflakeSQLException: JDBC driver not able to connect to Snowflake. Error code: 390100, Message: Incorrect username or password was specified…”

However I can successfully connect to this DW via the command line utility SnowSQL and via the web interface using the same credentials.

My connection setup looks like it does in the attached image.

Any advice/suggestions welcome.

Thanks,
Nigel

Hi @Nige
Which version of Metabase? Do you see more details in the Metabase error log?

v0.32.8

All I see in the log is the same error that gets displayed on the screen:

Jun 10 11:36:53 DEBUG metabase.middleware.log :: POST /api/setup/validate 400 194 ms (0 DB calls) {:errors {:dbname “net.snowflake.client.jdbc.SnowflakeSQLException: JDBC driver not able to connect to Snowflake. Error code: 390100, Message: Incorrect username or password was specified…”}}

@Nige
I’m not sure what’s going on. If you’re totally sure that you’re using the same credentials and connection details, then I think you need to use Wireshark to see if you can spot what’s going on.
Maybe the credentials are only valid for specific IP addresses?

@flamber Thanks for your thoughts.

Turns out it is the dialog uses a deprecated format. Region ID is now combined with account name for the JDBC connection (See the official Snowflake doumentation). You have to enter account name and region Id separately in the Metabase dialog (you should be able to combine them). I have raised issue #10142 on GitHub for it.

1 Like

Just for visibility:

1 Like