[SOLVED] Not able to test send an e-mail while I am creating a Pulse

I am creating a new Pulse but when I hit the “Send email now” button, is errors out “Sending Failed” and I have the following error in the server log:

09-04 11:57:51 ^[[1mERROR metabase.middleware^[[0m :: ^[[31mPOST /api/pulse/test 500 (57 ms) (13 DB calls).^[[0m
{:message “Don’t know how to create ISeq from: metabase.pulse.render$section_style”,
:type java.lang.IllegalArgumentException,

Any idea?

I tried reproducing your problem but was not able to, so I basically just wasted my time.

I don’t know what version of Metabase you are on, I don’t know what steps you took to get this error …

In general when asking for help when you experience an error it’s a good idea to provide some info like Please read me before reporting a bug! suggests.

Thanks for educated me. I checked the reported bugs but I couldn’t find some equal to my error message. Follow below more details:

Metabase Hosting OS: Oracle Linux Server release 7.3
Client OS: Windows 10 (64 bits)
Browser version: Chrome 69.0.3497.81 (Official Build) (64-bit)
Metabase DB: H2
Metabase Version: 0.28.5
Metabse database which I am connecting to: Oracle 12c

Repeatable steps to reproduce the issue:
In the Admin panel, Email settings I have the following configuration:
SMTP HOST: mysmtpserver.com
SMTP USERNAME: (leave in blank)
SMTP PASSWORD: (leave in blank)
FROM ADDRESS: Metabase_DEV@Mycompany.com

Here if I click in Sent test e-mail, it works OK

Now, when I am setting a new pulse, I set the To: to my user but when I click in the "Send email now” button, is errors out “Sending Failed” and I see the log reported above.

Appreciate you’re getting back with such a clear description. Now I don’t think I wasted my time any more :slightly_smiling_face:

I checked the changes to source since v0.28.5 but didn’t see any smoking gun with exactly the error you experience fixed. I did however see changes go into version 0.29 regarding rendering of pulses which is part of the error you get:

Also since I have it working with v0.30 I suggest you try upgrading and see if it fixes the bug.

After upgrade to the latest version, this issue has gone. Tks.

1 Like