"Sorry, you don’t have permission to see that" while running the native query as admin

Diagnostic Info
"browser-info": {
"language": "en-US",
"platform": "Linux x86_64",
"userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.64 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.15+10",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "https://adoptium.net/",
"java.version": "11.0.15",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.15+10",
"os.name": "Linux",
"os.version": "5.4.0-110-generic",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "14.2 (Debian 14.2-1.pgdg110+1)"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.3.2"
"run-mode": "prod",
"version": {
"date": "2022-05-02",
"tag": "v0.43.0",
"branch": "release-x.43.x",
"hash": "ee686fc"
"settings": {
"report-timezone": "Asia/Dhaka"

While trying to run native query as admin getting the page Sorry, you don’t have permission to see that

Hi @shihab
That is most of the time caused by a reverse-proxy like a WAF:
But if you are using Click Behaviors, then it can be caused by that in some cases:
https://github.com/metabase/metabase/issues/15993 - upvote by clicking :+1: on the first post

Actually i'm converting a question to SQL and try to run i get " Sorry, you don’t have permission to see that."

Though i'm admin

@shihab Then it's caused by a reverse-proxy. Check the headers returned in the request to help you figure out where the problem is coming from.