Sqlite timestamp field imported as 1970

I've just connected my sqlite db with some values and a timestamp field as below:
time TIMESTAMP NOT NULL DEFAULT (strftime('%s', 'now')),

sample value in this field is: 1668459571 -> which is a valid timestamp, it's just in seconds instead of milliseconds.

But metabase insists on importing it as "January 20, 1970, 7:41 AM", I'm unable to see any option to change it or cast it anywhere!

How can I get proper values for this field? I even tried deploying a postgres db instead of H2 but still same behavior.

Hi @pseudozach
Unless you cast the field, then Metabase doesn't really know what it is.