SSH tunneling


I'm trying to make SSH tunneling works to connect a Mysql database but I had an error :
DefaultAuthFuture[ssh-connection]: Failed (NoSuchProviderException) to execute: JCE cannot authenticate the provider BC

I think that is BouncyCastle related, but I don't find how to fix it.
I added BC like a security provider, I tried multiple ways, but still not working.

Does someone know how to figure out ? Or there is a way to change in metabase the security provider ?

Server is on java version

Thank you

Hi @gloeyn
Post "Diagnostic Info" from Admin > Troubleshooting.
Use Java 11 (or 17):
Have you looked at Mysql database connect fail or MYSQL database connection error

Thank you

Yes I took a look at these topics, but it seems to be a different problem
I will try to test Java 17

Here the diagnostic info :

"browser-info": {
"language": "fr-FR",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "Java(TM) SE Runtime Environment",
"java.runtime.version": "",
"java.vendor": "Oracle Corporation",
"java.vendor.url": "",
"java.version": "",
"": "Java HotSpot(TM) 64-Bit Server VM",
"java.vm.version": "",
"": "Linux",
"os.version": "4.9.0-18-amd64",
"user.language": "en",
"user.timezone": "Etc/UTC"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "mysql",
"application-database-details": {
"database": {
"name": "MariaDB",
"version": "10.1.48-MariaDB-0+deb9u2"
"jdbc-driver": {
"name": "MariaDB Connector/J",
"version": "2.7.5"
"run-mode": "prod",
"version": {
"date": "2022-06-13",
"tag": "v0.43.3",
"branch": "release-x.43.x",
"hash": "c9c7ef0"
"settings": {
"report-timezone": null

@gloeyn Quite sure that it is caused by bad Java environments. It's been reported 3 times, and all of them were using random Java versions. Otherwise there's a workaround, by creating a tunnel outside of Metabase: Mysql database connect fail

Thank you @flamber

I tried different java version, from 11 to 17, without any success.
But I finally got something while I switch to OpenJDK ! Whatever the version, it works with OpenJDK.