Unable to connect to Druid

I keep received below message while i tried to add druid into metabase.

[97386876-bb37-4737-badf-6003db7071b6] 2019-11-26T11:39:05+08:00 DEBUG metabase.middleware.log POST /api/database 400 1.4 s (0 DB calls)
{:valid false, :dbname “no protocol: 10.1.1.20:8082/status”, :message “no protocol: 10.1.1.20:8082/status”}

{
  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36 OPR/65.0.3467.48",
    "vendor": "Google Inc."
  },
  "system-info": {
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "1.8.0_222-b10",
    "java.vendor": "Oracle Corporation",
    "java.vendor.url": "http://java.oracle.com/",
    "java.version": "1.8.0_222",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "25.222-b10",
    "os.name": "Linux",
    "os.version": "3.10.0-693.el7.x86_64",
    "user.language": "en",
    "user.timezone": "Asia/Singapore"
  },
  "metabase-info": {
    "databases": [
      "postgres"
    ],
    "hosting-env": "unknown",
    "application-database": "postgres",
    "run-mode": "prod",
    "version": {
      "tag": "v0.33.6",
      "date": "2019-11-19",
      "branch": "release-0.33.x",
      "hash": "be1e0e1"
    },
    "settings": {
      "report-timezone": "Asia/Kuala_Lumpur"
    }
  }
}

Hi @i2cute
I don’t use Druid, but since the error is “no protocol”, I would guess it’s because you entered 10.1.1.20 as host instead of http://10.1.1.20 ?

Thanks so much. http is required for the connection, never thought about it.

Really appreciate it :smiley: :+1::+1:

1 Like

Sorry, 1 more question, how to pass in druid username password? :blush:

@i2cute I don’t think you pass those - I think it asks for username/password on save and then a token is stored, but I have no idea how Druid works.