Unable to connect to Metabase with SQL Database

I tried configuring Metabase on my local MAC machine using SQL database, the connection worked smoothly, However when I try to connect to Metabase on my production machine even through its own local firefox browser, I am unable to connect

OS : Linux
Metabase version v0.35.4
MySQL version

| Variable_name | Value |
| immediate_server_version | 999999 |
| innodb_version | 8.0.20 |
| original_server_version | 999999 |
| protocol_version | 10 |
| slave_type_conversions | |
| tls_version | TLSv1,TLSv1.1,TLSv1.2 |
| version | 8.0.20 |
| version_comment | MySQL Community Server - GPL |
| version_compile_machine | x86_64 |
| version_compile_os | Linux |
| version_compile_zlib | 1.2.11 |

Error message

Hi @s1joshi
Because you are trying to connect to localhost, which is the name of each individual computer, so it worked on your local computer, since your database is also running on that.

I am accessing using the firefox of same production system.

Also tried externally using the IP but the problem persist.

@s1joshi I don’t think you quite understand how networking works. This has nothing to do with your browser, but the connection between Metabase and MySQL.
Check your firewalls, figure out how to host MySQL, so Metabase can access it.

The metabase setup and the DB both are running on the same machine, am accessing it through the browser of same machine, When everything is local,
External access would entail firewall and other considerations, my question is when everthing is local, why it is not picking.

To me it seem something to do with MySQL password algorithm & the authentication mechanism which changed after around version 5.0.

@s1joshi Version 5.0 of what? The log, which you have chosen to have on Google Docs instead of including it here, shows that it’s failing to connect to localhost:3306

You said in the beginning that connection works on your local computer, but when you try to setup Metabase on production machine (which I guess is a different computer from your local computer), then it doesn’t work.
If that’s the case, then it is caused by the MySQL server running on your local computer, which your production computer doesn’t have access to.

Otherwise try making a network diagram that shows how things are connected and it’s IP addresses.

@s1joshi And if you are having problem with RSA, then it’s not indicated in that log, but then have a look at this issue for workarounds:

There is file type restriction and text size restriction, hence uploaded error on Google drive link

Here is the working and non working setup :slightly_smiling_face:

@s1joshi Post “Diagnostic Info” from Admin > Troubleshooting - of the production system.