[Urgent] Admin settings not visible under settings after Metabase Upgrade v0.46

Description : When upgrading Metabase v0.46 from v0.41 we encountered this issue while trying to deploy metabase application in Openshift pod.
Can anyone please help here why only Admin settings didn't appear in UI ??

{
  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.0.0 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "ANSI_X3.4-1968",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.18+10-LTS",
    "java.vendor": "Red Hat, Inc.",
    "java.vendor.url": "https://www.redhat.com/",
    "java.version": "11.0.18",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.18+10-LTS",
    "os.name": "Linux",
    "os.version": "4.18.0-305.88.1.el8_4.x86_64",
    "user.language": "en",
    "user.timezone": "America/New_York"
  },
  "metabase-info": {
    "databases": [
      "h2",
      "oracle",
      "mysql",
      "mongo",
      "sqlserver",
      "postgres"
    ],
    "hosting-env": "unknown",
    "application-database": "mysql",
    "application-database-details": {
      "database": {
        "name": "MySQL",
        "version": "8.0.29"
      },
      "jdbc-driver": {
        "name": "MariaDB Connector/J",
        "version": "2.7.6"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2023-06-08",
      "tag": "vUNKNOWN",
      "branch": "?",
      "hash": "cdb9b23"
    },
    "settings": {
      "report-timezone": null
    }
  }
}

Please note : We have tried clearing cache and then tried metabase URL but no luck.

that's a custom build of Metabase, can you give us info about which changes you made?