X-axis miss-alignment w/area [SOLVED]

Is there a workaround for this? Area x-axis markers/labels don’t play nice with lines or columns on a split y-axis. Surely someone’s noticed this before but I can’t find it in Discourse or GitHub. If a makes a difference year isn’t a date in this case, it’s a number converted to text to avoid the comma.

Line & Column (fine)



Line & Area (not so fine)

Both Area (fine again)

Metabase jar: v0.33.2
Host: Localhost:3000
Databases: H2 internal default, Server SQL added
Browser: Firefox 52.9.0
OS: Microsoft Windows [Version 6.0.6002]
Java: 1.8.0_45

@mesquest
Try setting scale back to Timeseries, and make it return YEAR() or a number and then try changing format in visualization Settings > Data > Year to avoid the comma.
Try with 0.33.4 - there has been several changes to visualizations since 0.33.2
For the Ordinal issue (and Histogram), I’ve created an issue:

1 Like

Thanks for pointing me in the right direction @flamber, it was just a matter of not converting the year in sql to a varchar (was the only way to avoid commas up until fairly recently) and formatting the x-axis as numbers in a couple of places:


Line & Area (now they play nice together!)

1 Like