0.28.1 on AWS EBS with https

I am not able to force HTTPS anymore after upgrading.

I’m running:

64bit Amazon Linux 2017.09 v2.8.4
Docker 17.09.1-ce

I have a env property: NGINX_FORCE_SSL = 1
as well as:

and yet, I can still access the installation under http:// without a redirect. Any thoughts?

1 Like

Actually, maybe what i’m trying to get to is disabling access to the ebs url directly, and only supporting access from my custom domain.

I’m trying to do the same thing, and not sure how to force http:// to redirect to https://

I have Docker + Nginx + Metabase 0.32

Anymore? Are you saying it’s a regression since a previous release, and you have steps to reproduce vs show it’s working in an older release? Then I think a bug report on GitHub is appropriate

(sorry not using AWS ELB myself, so can’t really help with the specifics)

@jontsai even though your goal is the same as OP your environment is not the same: AWS EBS

Using https: with Docker might be useful in your case though (BTW impressive that you are on that Metabase version already :wink:

Sorry, I forgot to mention that I am also using AWS ELB (Elastic Load Balancer, I think not EBS?), so the HTTPS resolves at that layer, and everything behind the load balancer is just plain HTTP.

I tried various Nginx configurations (basically, listening on port 80, forwarding to port 3000), similar to the link you shared.

Most of the configuration examples that I read involve listening on port 80; and then redirecting to port 443; with port 443 being the actual one configured with SSL. That would work on a single server setup and SSL being resolved at the server level.

So, yes, I do have the same issue, of needing to enforce HTTPS, but have SSL terminate on the load balancer.

Would it be possible to add some sort of setting to Metabase to allow enforcing an automatic redirect to the configured “SITE URL” setting in Settings > General? Other software like WordPress does this.

I would be okay with an automatic redirect, or a checkbox setting that I could turn on or off.

1 Like