A couple questions about SQL Server connection

We are trying to use Metabase with a production DB. It is substantially large, on the order of several TB. When we had given Metabase read access to most tables, it started doing so many SELECT’s that it blocked other users out. This was even before we started asking questions and creating dashboards. Right now we have disabled the credentials pending investigation.
Is turning off in-depth analysis enough to prevent excessive DB traffic?

And, on an unrelated topic: when working with test dataset we encountered an issue when applying filters by datetime in our questions. Metabase reports an error: “Type date is not a defined system type.” Is it supposed to use datetime instead of date? We had to abandon GUI for now and resort to raw SQL questions.

If you unselect In-depth analysis, it won’t scan the individual columns or do anything other than read in the schema from your database.

Thanks, we will try with in depth analysis disabled.

What about the date vs datetime types?

it should work. what db and version of metabase are you using?

We use Metabase 0.19.3 on CentOS, connected to SQL Server 2005.

When I enter questions with SQL and filter results by DATEADD(day, -1, GETDATE()), everything works fine.
MSDN says that return type of DATEADD is datetime.

However, when I try to create a question using the GUI, it seems to use date type for the filter and SQL Server returns an error: “Type date is not a defined system type.”

Is it possible to make the GUI use datetime?

Offhand, we don’t support SQL server versions that old - https://github.com/metabase/metabase/issues/2330

There was some wonkiness in SQL Server 2008 re: date handling. If you can figure out what the root cause of this is, we might fix it, but in general, we don’t plan on spending too much time digging into issues in database versions that old.