Adding new users - no Password

As Admin, have added 3 new users to Metabase.
It is written in the documentation that when you do not have the email SMTP configured, Metabase will give you instead a temporary password that you’ll have to send to the person you’re inviting by hand.

But how?
I am not seeing any password, nothing appears, and also don’t receive anything in the mailbox associated to my Admin Metabase account. Where can I find those passwords so that I can send it to them myself?

Same for when I try to reset them:
I get the popup:
Reset xxxx’s password?
Are you sure you want to do this?

But when I click the popup goes away, but no password.
In the documentation I also did not see how the user’s password should be shared with me.

Is this a bug, or am I overlooking something?

Hi @Jansen
Please post “Diagnostic Info” from Admin > Troubleshooting.
The password is sent to the user’s email address - not to the admins.
Check log, when you set password to see if there’s an error during the mail process - Admin > Troubleshooting > Logs.
And check your SMTP server logs for activity.

Thanks @flamber for your fast reply!

I dont have the SMTP configured for Metabase. Our domain is blocking Metabase as an untrustworthy app, and our IT is not confident to allow or make changes to it.

Therefore I was going for the alternative option, mentioned here:

Where it states:
Otherwise, it’ll give you a temporary password that you’ll have to send to the person you’re inviting by hand.

It says “it will give you”, but how/where does it give it?
And is sending the troubleshoot data still relevant when the issue is not the SMTP but the “it gives you” part of the password sharing? Since I guess that is not done through email, since it is offered as alternative if you dont set up SMTP.


  1. Please post “Diagnostic Info” from Admin > Troubleshooting.
  2. Are you sure that you haven’t configured SMTP at some point and didn’t clear it? Admin > Settings > Email.
    If you have just cleared it, then you need to refresh you browser, when resetting password for the user for it to show the dialog with the password.
1 Like

Awesome! You are great @flamber! Thanks. After clearing cache it is working. Now I get the popup.