Alerts not firing even after the confirmation mail

Metabase v0.31.2:

I have created an “hourly” alert for a question and even got the confirmation mail that alert has been setup. When I send GET request to /api/alert/<alert_no>, I’m able to see the alert in JSON format too. But, I’m still not getting any mails.

@r-maya
I would recommend that you try 0.32.1, which has a new Troubleshooting in the Admin section.
It should help with finding stale pulses or connection errors.
Remember to backup before upgrading.

Hey,thanks for the reply.

I’m running metabase on docker. When I tried upgrading the metabase, it said disk space not left. So I ran the command

docker system prune -a (to free the space)
Then

docker pull metabase/metabase
which was successful.

But when I’m trying to run

docker run -p 1234:3000 -v ~/metabase/data:/tmp -e MB_DB_FILE="/tmp/metabase.db" --name metabase-0-32-1 metabase/metabase

This is the output that I’m getting:

Extract file /modules/bigquery.metabase-driver.jar -> /plugins/bigquery.metabase-driver.jar took 2 ms
INFO plugins.lazy-loaded-driver :: Registering lazy loading driver :presto…
04-01 09:25:29 INFO metabase.driver :: Registered driver :presto (parents: #{:sql}) :truck:
04-01 09:25:29 INFO plugins.dependencies :: Plugin ‘Metabase BigQuery Driver’ depends on plugin ‘Metabase Google Drivers Shared Dependencies’
04-01 09:25:29 INFO plugins.dependencies :: Metabase BigQuery Driver dependency {:plugin Metabase Google Drivers Shared Dependencies} satisfied? false
04-01 09:25:29 INFO plugins.dependencies :: Plugins with unsatisfied deps: [“Metabase BigQuery Driver”]
04-01 09:25:29 INFO plugins.lazy-loaded-driver :: Registering lazy loading driver :sqlite…

Okay, so there’s a few things.

  1. I would recommend that you do not use H2 as your production database - you’ll end up with a corrupted database at some point
    https://www.metabase.com/docs/latest/operations-guide/start.html#migrating-from-using-the-h2-database-to-mysql-or-postgres
  2. Make sure you’re setting the timezone - there are multiple places to do that:
    https://www.metabase.com/docs/latest/troubleshooting-guide/timezones.html
    https://wiki.alpinelinux.org/wiki/Setting_the_timezone
  3. The errors/warnings are probably hiding earlier in the log - it’s only displaying a few lines.