All results grayed out

So for a while now (since earlier versions, and through several upgrades), any result in metabase (whether browsing db tables or viewing questions) are always grayed out like it is still processing the results. It seems as if the overlay that grays results and prevents interaction with them is not getting removed. We are running metabase in a kubernetes cluster, using the standard helm chart to install and do upgrades (see

Update: It is the overlay, as I can do “$(’.Loading’).remove()” in my browser’s console to make the results look normal.

  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.116 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.5+10",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "",
    "java.version": "11.0.5",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.5+10",
    "": "Linux",
    "os.version": "4.4.111+",
    "user.language": "en",
    "user.timezone": "UTC"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "9.6.16"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.8"
    "run-mode": "prod",
    "version": {
      "date": "2020-04-02",
      "tag": "v0.35.1",
      "branch": "release-0.35.x",
      "hash": "e67f169"
    "settings": {
      "report-timezone": null

Hi @kbo
I’m guessing this is you?
Are you using a reverse-proxy or a WAF (example Cloudflare)?
Have you tried a different browser (preferably on a different computer, on a different network)?
There should be errors in your browser console - I don’t think you’ll find any errors in the log (Admin > Troubleshooting > Logs), but have a look there too.

Yep, that was me. I decided to post here before creating a ticket this time.
I do believe we are using a reverse proxy (Nginx) in front of metabase.
We have tried different users/browsers/networks without success.
The only console errors I see appear to be font-related:
(index):1 Refused to load the font 'data:font/woff;base64,...
I didn’t see anything in the logs that looked related. Only INFO and DEBUG messages.

@kbo I’m almost 100% sure that some proxy is doing something it shouldn’t.
There’s thousands of installations of Metabase, but it’s the first time I’ve seen this problem.

I’ll check this out more, but it appears the proxy is passing the headers directly from metabase and isn’t modifying any requests. I’m getting a CSP error for fonts, because “font-src” is set to “self” and there are “data:” fonts that are getting rejected. This appears to be how metabase is set up, and may even be a bug. Do you think that the fonts could be causing our issue? Any other ideas on what we can check on?

@kbo If we go back to the screenshot you provided in the issue, then you can clearly see that the UI does not look correct, so something is being changed.
Make it very simple, avoid any proxies and see if that makes a difference - I’m 100% sure it will work.

Thanks for the help. We haven’t fixed the issue yet but were able to bypass the proxy to confirm that it is indeed the issue.

1 Like