Anyway to disable SQL editor autocomplete

Is there a way to disable autocomplete in the SQL editor or change to tab autocomplete from return? I find myself constantly hitting escape to stop it from choosing an option I don’t want.

You could try using NoScript or one of the other browser plugins that allow you to control JavaScript. Other than that, it can’t be disabled.