Archive not working properly

Hey!
Im having some issues whet trying to retrieve archived questions. When I open the archive page it only shows some of the questions on it and the rest of the page is blank (even the scrollbar works like there was a huge list of archived questions but they are all whitespaces).
I tried it on Google Chrome, Microsoft Edge and Firefox and it doesn't seem like a browser issue.

Hi @gabi
Post "Diagnostic Info" from Admin > Troubleshooting.

{
"browser-info": {
"language": "pt-BR",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.0.0 Safari/537.36",
"vendor": "Google Inc."
},
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.15+10-Ubuntu-0ubuntu0.20.04.1",
"java.vendor": "Private Build",
"java.vendor.url": "Unknown",
"java.version": "11.0.15",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.15+10-Ubuntu-0ubuntu0.20.04.1",
"os.name": "Linux",
"os.version": "5.13.0-1023-aws",
"user.language": "en",
"user.timezone": "Etc/UTC"
},
"metabase-info": {
"databases": [
"postgres"
],
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "12.8"
},
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.3.2"
}
},
"run-mode": "prod",
"version": {
"date": "2022-05-02",
"tag": "v0.43.0",
"branch": "release-x.43.x",
"hash": "ee686fc"
},
"settings": {
"report-timezone": null
}
}
}

@gabi Upgrade to 0.43.4: https://github.com/metabase/metabase/releases/latest

Did the upgrade and its still not working =(

@gabi I've created an issue for it:
https://github.com/metabase/metabase/issues/24213 - upvote by clicking :+1: on the first post