Athena DB Connection can't add

  1. my system config is follow:

  2. i try to add athena db database connection, but time error occur.

  3. fail log is follow:

  4. when i login aws and check athena previous query history,
    I can find simple query execution is success

  5. so i operate this to old server that already operate fine
    then i can add athena connection.

  6. {
    "browser-info": {
    "language": "ko",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.0.0 Safari/537.36",
    "vendor": "Google Inc."
    },
    "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "1.8.0_242-b08",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "http://java.oracle.com/",
    "java.version": "1.8.0_242",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "25.242-b08",
    "os.name": "Linux",
    "os.version": "4.15.0-163-generic",
    "user.language": "ko",
    "user.timezone": "Asia/Seoul"
    },
    "metabase-info": {
    "databases": [
    "athena"
    ],
    "hosting-env": "unknown",
    "application-database": "mysql",
    "application-database-details": {
    "database": {
    "name": "MySQL",
    "version": "5.7.36-0ubuntu0.18.04.1"
    },
    "jdbc-driver": {
    "name": "MariaDB Connector/J",
    "version": "2.7.5"
    }
    },
    "run-mode": "prod",
    "version": {
    "tag": "v0.43.3",
    "date": "2022-06-13",
    "branch": "release-x.43.x",
    "hash": "c9c7ef0"
    },
    "settings": {
    "report-timezone": "Asia/Seoul"
    }
    }
    }

what do i have to check for this error ?
For check access I make sample spring-boot demo and it work success in this server.
and athena.ap-north-2.amazonaws.com 443
image

Hi @beomkyu

  1. Update to Java 11: https://www.metabase.com/docs/latest/operations-guide/java-versions.html
  2. Make sure you're using 1.4.0 of the driver: https://github.com/dacort/metabase-athena-driver/releases
  3. Your log looks off, seems like you are using a custom Log4j configuration, which is not valid.

thank 's for your answer.
i adjust what you suggest.

  1. use java11
  • already use java11 but it didn't work.
  1. already check the version of impala driver
  2. i use jar file with this configuration and the format for logging guided metabase web page
    https://www.metabase.com/docs/latest/operations-guide/log-configuration.html

    java -Dlog4j.configurationFile=file:/log4j2.xml -jar metabase.jar &

@beomkyu

  1. You were using Java 8.
  2. I don't understand why you are talking about Impala driver, when you are talking about Athena.
  3. Post your Log4j configuration or remove it, so it just uses the default configuration. And enable more logging in the driver: https://github.com/dacort/metabase-athena-driver#configuring

sorry. i akward to use english .
after i ckeck all of my configuration. i figure out that should have to add additional paramter
: UseResultsetStreaming=0
before add parameter metabase tried to connect with 444 port . and that's why i can add connection.
now It's solved