Authentication error with Google SSO

I have a user that’s trying to log in with Google but is unable to do so. Putting logs here:

[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:35-07:00 INFO metabase.api.session Successfully authenticated Google Auth token for: Tanner Tew
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:35-07:00 DEBUG metabase.middleware.log POST /api/session/google_auth 200 95.6 ms (3 DB calls) App DB connections: 1/15 Jetty threads: 3/50 (8 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:35-07:00 DEBUG metabase.middleware.log GET /api/user/current 200 3.1 ms (3 DB calls) App DB connections: 0/15 Jetty threads: 3/50 (8 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:35-07:00 DEBUG metabase.middleware.log GET /api/database 200 5.2 ms (4 DB calls) App DB connections: 0/15 Jetty threads: 3/50 (8 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:35-07:00 DEBUG metabase.middleware.log GET /api/collection/root/items 200 4.3 ms (3 DB calls) App DB connections: 0/15 Jetty threads: 3/50 (8 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:36-07:00 DEBUG metabase.middleware.log GET /api/card/329 200 149.4 ms (6 DB calls) App DB connections: 3/15 Jetty threads: 5/50 (6 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:36-07:00 DEBUG metabase.middleware.log GET /api/database 200 178.4 ms (9 DB calls) App DB connections: 0/15 Jetty threads: 4/50 (7 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:36-07:00 DEBUG metabase.middleware.log GET /api/database 200 194.8 ms (4 DB calls) App DB connections: 0/15 Jetty threads: 3/50 (8 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:36-07:00 DEBUG metabase.middleware.log GET /api/alert/question/329 200 1.8 ms (1 DB calls) App DB connections: 0/15 Jetty threads: 3/50 (8 idle, 0 queued) (119 total active threads) Queries in flight: 0 (0 queued)
[9d6ed24b-fbb6-440b-9165-290bdc94527e] 2020-06-09T15:13:36-07:00 WARN metabase.middleware.log GET /api/table/card__306/query_metadata 403 3.9 ms (3 DB calls)
"You don't have permissions to do that."

There is a permissions error below that I’m putting just in case but don’t think is a problem. Tried with a different user with same permissions levels and it works fine.
I tried what @flamber suggested here: [SOLVED] Cannot sign in using Google and being told I am not a user?
but no luck

{
  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.5+10",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.5",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.5+10",
    "os.name": "Linux",
    "os.version": "4.14.138-89.102.amzn1.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  },
  "metabase-info": {
    "databases": [
      "h2",
      "sqlserver"
    ],
    "hosting-env": "elastic-beanstalk",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "10.6"
      },
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.8"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2020-04-10",
      "tag": "v0.35.2",
      "branch": "release-0.35.x",
      "hash": "f3b2857"
    },
    "settings": {
      "report-timezone": "US/Pacific"
    }
  }
}

This is what the user sees when he logs in. So authentication is passing threw but not able to use metabase. He tried incognito window

Hi @fera320
Latest release is 0.35.4

So you’re not getting authentication error - the Google login works.
But you cannot access a specific table - permission error.

  • The other user, is that a Google login as well?
  • Are they part of the same groups? Admin > People
  • What level of permissions have you applied to database/tables and collections? Admin > Permissions
  • What are the steps-to-reproduce? It looks like you’re trying to do a drill-through with a user that doesn’t have data-access