Autocomplete in filter broken because of recent feature

Hello here

We updated our Metabase instance to the last version to get the log4j patch.

However, this new version comes with a new way to autocomplete in the search in filter. The search is now infix, where it use to be prefix.

Source for this evolution

We had the proper index (postgresql, covering B-tree on (lower(column), column)) to autocomplete instantly on a 20 millions lines table.

With the new mecanism, we cannot find an index efficient enough. Hence our website is completely broken.

Do someone have ideas on what we should do ?

Maybe Metabase will give the option to choose how to autocomplete in the future ?
Or would it be easy to fork a version without this evolution (but with log4j patch) ?

To give some context, we are an NGO working on transparency in health.
Our websites (the broken one) and
Our gitlab account :

Any help welcome ! :slight_smile:

Hi @paj
We're working on a lot of filter changes, but when/if it would fix your problem, I cannot tell.
But you'll just need to modify one line (from what I can tell) if you created your own build:

1 Like

wow, thanks a lot for this very fast answer !

I'll try to build our own dockerised version with this change then.