AWS Elastic Beanstalk (Upgrade 0.47.1)

Good morning! This morning I went to upgrade Metase (0.47) to Patch 0.47.1 on AWS Elastic Beanstalk and I couldn't find the file to download. Researching further I found the following message on your website link "Due to problems with the platform, we no longer recommend using Elastic Beanstalk to run Metabase in production". Are you discontinuing Metabase for AWS EBS? Do you have any plans for the AWS EBS version to be made available?
Thank you in advance for your attention and support.
Thank you very much
Tiago Silva

We’re no longer recommending Metabase on Beanstalk. Many users coming to us with problems that they didn’t know how to fix, so we can’t recommend a platform that will give us more problems than what we can handle. Building a beanstalk artifact is easy: just open the zip file, modify the json file and zip it again

Thank you Luiggi! I'll try it and let you know.
Have a good day!
It's working thank you

Hi, we tried to update from 0.47.0 to 0.47.2 using your suggestion, but with no luck :confused:

  "AWSEBDockerrunVersion" : "1",
  "Image" : {
    "Name" : "metabase/metabase:v0.47.2",
    "Update" : "true"
  "Ports" : [ {
    "ContainerPort" : "3000"
  } ],
  "Logging" : "/var/log/metabase"

Also tried "Name" : "metabase/metabase:latest"

And for the record, we have run Metabase for years on ELB without any trouble regarding the platform.

Please post the error you saw when upgrading

from eb-engine.log
2023/09/25 11:49:23.909404 [INFO] Error occurred during build: Command 01-persist_env_vars failed

from cfn-init-cmd.log

2023-09-26 08:53:08,698 P4306 [INFO] /bin/sh: .ebextensions/metabase_config/ Permission denied

could it be an issue with using windows to re-zip the deployment package?

yes, that was the problem :face_with_spiral_eyes:
The latest artifact seems to still exist, even if not obviously linked to in the docs. :slight_smile: worked for my deploy!


Hi sao,

I am experiencing the same error, how did you get around this?

Set up an Ubuntu Sub-system on windows

There you may unpack, change version, and re-zip deployment package:

cd metabase-aws-eb/
zip -u


I set up wsl and it worked. Thank you!

This solution worked for me too