AWS Elasticbeanstalk - error while upgrading from 0.30.4 to 0.31.2


#1
2019-02-12 12:54:40 UTC+0200 ERROR During an aborted deployment, some instances may have deployed the new application version. To ensure all instances are running the same version, re-deploy the appropriate application version.
2019-02-12 12:54:40 UTC+0200 ERROR Failed to deploy application.
2019-02-12 12:54:40 UTC+0200 ERROR Unsuccessful command execution on instance id(s) ‘i-0c526a7de11fa325e’. Aborting the operation.
2019-02-12 12:54:40 UTC+0200 INFO Command execution completed on all instances. Summary: [Successful: 0, Failed: 1].
2019-02-12 12:54:39 UTC+0200 ERROR [Instance: i-0c526a7de11fa325e] Command failed on instance. Return code: 1 Output: nginx: [emerg] no host in upstream “:3000” in /etc/nginx/conf.d/elasticbeanstalk-nginx-docker-upstream.conf:2 nginx: configuration file /etc/nginx/nginx.conf test failed Failed to start nginx, abort deployment. Hook /opt/elasticbeanstalk/hooks/appdeploy/enact/01flip.sh failed. For more detail, check /var/log/eb-activity.log using console or EB CLI.
2019-02-12 12:54:35 UTC+0200 ERROR Failed to start nginx, abort deployment
2019-02-12 12:54:10 UTC+0200 INFO Successfully built aws_beanstalk/staging-app
2019-02-12 12:54:09 UTC+0200 INFO Successfully pulled metabase/metabase:v0.31.2
2019-02-12 12:53:53 UTC+0200 INFO Deploying new version to instance(s).
2019-02-12 12:53:49 UTC+0200 INFO Environment update is starting.

#2

@bezl
Do you have any details from the Metabase log, why it failed to start/migrate?


#3

I’ve tried it few times - it was the same mistake, then I’ve stopped the App server in the beanstalk and it launched new App server automatically. Then when I’ve launched migration process on the new App server - it worked well!