Big Query Field Filter Issue

When using field filters in big query, the field filter substitutes itself to be schema.dbName.columnName
where as only dbName.columnName is required

[[and {{business_id}}]]

substitutes to

and (`public.med_order_attributes`.`business_id` = 'MERADOC')

here public is the schema, I ran same query in looker minus the schema name and it worked

Does it also work with the schema name (public) included?

No, that is the issue, big query doesn’t let you access column name from schema.dbName. columnName

What version of Metabase are you on?

Using the metabase cloud, not self hosted

If you're a Cloud customer please send an email to to submit a ticket.

I did test this locally and queries that include the BQ schema do execute without error for me. In BQ directly I cannot execute a query without dataset defined - it requires it. I suspect this may have something to do with the service account permissions. Perhaps the dataset is already defined in Looker or the service account Looker uses only has access to a single dataset?