BigQuery connector issues

Hi, I seem to be stumbling upon an issue when trying to connect BigQuery to metabase. I have the correct project id and a working key token from my big query service account. I tried creating a new key token and it still doesn't work. I made sure that my service account has also the required permissions in the documentation but I am still getting an error when trying to connect.

The error usually comes up as HTML that says

"Oops, something has gone wrong here. I've notified the tech team and they will look into it."
"If you try again in a little while we'll be back"

What is going on here? I checked the other settings but not of them seem relevant to access levels. I've tried on different days too with the same error. I've created a new service account to no avail.

Running out of ideas at this point, so any help would be appreciated thanks.

Hi @Dshall
Post "Diagnostic Info" from Admin > Troubleshooting.
I don't know where that error is coming from, but it's definitely not Metabase.

Hi thanks for your response. Here is the diagnostic info. The service account works when trying to access Big Query from other sources such as databricks.

"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.124 Safari/537.36 Edg/102.0.1245.41",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.15+10",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "",
"java.version": "11.0.15",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.15+10",
"": "Linux",
"os.version": "5.4.0-1074-azure",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "11.15"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.3.2"
"run-mode": "prod",
"version": {
"date": "2022-06-13",
"tag": "v0.43.3",
"branch": "release-x.43.x",
"hash": "c9c7ef0"
"settings": {
"report-timezone": null

@Dshall Okay, I'm guessing that you have a reverse-proxy messing with the requests, since the errors you posted are definitely not coming from Metabase.