Bigquery timeout error

How do I increase the timeout of a query in bigquery that takes longer than the default timeout, think is 30 seconds.
How do I change that configuration ?
I am on version 0.45.1

The timeout is defined by the reverse proxy, how did you deploy Metabase?

Hmm...I will check with the deployment team. We did it we GKE but not sure we have a reverse proxy but need to check. Is that the only way this setting is set?

I found a solution.
Need to add a backendconfig in the load balancer of GKE.
Please check this docs: