Blank screen after changing and running saved query

we are running metabase in version 0.43.2
When I change a saved query and run it, my screen gets blank. Happens in firefox as well as in Safari. When I click the reload button on the browser, the query appears again, then again a blank screen.

Hi @EvaS
Check your browser developer console.
And I'm guessing this only happens on some questions? Can you include the question metadata by going to the URL /api/card/123, where 123 is the question ID?

Hi @flamber

as it only happens with unsaved queries (so its a saved query but one that I changed and did not save so far) I don't have a question id?

@EvaS All those errors are from browser extensions. Try another browser or disable all extensions.

I don't understand. You say that the problem happens, when you change an existing saved question.
Please try to reproduce the problem with Sample Database and record a video showing the problem.

Hi @flamber thank you! I will try with another browser (as said, it also does not work with Safari and this one is clean, no extensions as I never use it). (and I also did not add any extensions since we updated metabase, so before 43.2 it worked with my browser setup).

So the query is saved with a query_id. But the error only occurs when I change something in this query and then (without saving the changes) click on run.


Which version did you upgrade from?

Are you using a reverse-proxy, which is doing some magic it shouldn't?

So this happens to every single question you have, when you try to edit them ?
And it is also impossible for you to just go to New > Question > (db) > (table) ?

Hi, no it only happens to some questions, I just tried with the sample dataset and also with some other questions from our real datasets and they all work. Not sure where the difference is between the ones that go blank and the ones that work ...
I can create new queries and new questions, that all works. Its just with some saved queries that after I change them they go blank.
We upgraded from the previous version, must have been 43.1? (not sure though)

a workaround is to just save the query again (either with a new name or with the existing name) and it works again. Just not seems to work when changes are unsaved.

Exactly, it only happens to some questions.
So go to /api/card/123, where 123 is the question ID of a problematic question and paste the metadata.
Without understanding the metadata that is causing this problem, then it would be impossible to fix.

the metadata is quite long, anything in particular you are interested in for the screenshot?

@EvaS I don't want a screenshot. I want all the metadata as text. Otherwise you are more than welcome to figure out how to reproduce and open an issue on Github:

Hi, if that sounded like I don't appreciate your help, that is not correct. I do appreciate how you run the forum and are a walking encyclopedia for all of us. I don't use github that often for opening issues because it requires a certain level of technical expertiese that I don't have. I think thats what this forum is for. So please don't be offended by questions that are below your level of expertiese.

I will send you the txt file in a DM, I had to remove some sensitive info first.
Thank you for all your help, Eva

ah apparently I can't send you a PM, could you provide me with an emailaddress? thank you! Eva

@EvaS I had to block PM because everyone was trying to get private free support. My username and our domain, that's my email :slight_smile:

1 Like

haha yes even I get DMs sometimes with questions for help :smiley: I will send you the txt file right now. thank you!
Eva - upvote by clicking :+1: on the first post