Bug with new Bigquery driver

I try new Bigquery driver before switching production to it. But it has some error with field filter.
The first is running perfect, but the second variable is 400 error.
SQL : select * from performance
where {{project_code}}
[[ and {{country_code}} ]]
Error: 400 Bad Request POST https://www.googleapis.com/bigquery/v2/projects/test/queries { "code" : 400, "errors" : [ { "domain" : "global", "location" : "q", "locationType" : "parameter", "message" : "Unrecognized name: test.a.performance at [4:5]", "reason" : "invalidQuery" } ], "message" : "Unrecognized name: test.a.performance at [4:5]", "status" : "INVALID_ARGUMENT" }

Hi @hurtmenot
Post "Diagnostic Info" from Admin > Troubleshooting.
And the full stacktrace from Admin > Troubleshooting > Logs.

Currently I would guess the problem comes from your FROM-clause only containing the table and not the full reference:
https://www.metabase.com/docs/latest/users-guide/13-sql-parameters.html#the-field-filter-variable-type

Sorry I edit the sql.

@hurtmenot So your FROM-clause is just proj_cw.performance, but the Field Filter reference contains the project too `indiez-raw-data.proj_cw.performance`(and has backticks)
I'm guessing that is the problem.

Yeah right that is the problem. Thanks for your help