Can not connect to Mongo database (timeout after 10.0 s)

Hello there! The integration between mongo-metabase not working since we've created firewalls on our mondo database. Although we have added the required IPs to the mongo, it is still not working and I receive the following error:

DEBUG metabase.server.middleware.log POST /api/database 400 20.0 s (0 DB calls) {:valid false, :dbname "Timed out after 10.0 s", :message "Timed out after 10.0 s"}

The integration works when I connect to mongo dev db instead of prod which doesnt have a firewall. What could other reason be that causing that? Could you please help me?

  "browser-info": {
    "language": "en-GB",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "",
    "": "Linux",
    "os.version": "4.14.256-197.484.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "13.10"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.23"
    "run-mode": "prod",
    "version": {
      "date": "2022-02-28",
      "tag": "v0.42.2",
      "branch": "release-x.42.x",
      "hash": "d6ff494"
    "settings": {
      "report-timezone": null

Please upgrade to a more recent version. Also, re check the firewall rules

Hi Luiggi, thank you for your return!

I've checked the firewall rules with our development team a couple of times, adding Metabase IPs is supposed to work but it does not. Also, just fyi, I recently signed up for the trial of Metabase which has the latest version and tried to integrate mongodb, I did get the same timeout error. So, Im suspicious that the upgrade would solve the issue.

Is there something else I could do?

if you have signed up for the trial, then you have access to support, please send us an email so we can see the firewall rules and try to see with your network team what might be causing the issue

Hi Luiggi, we've signed up for the pricing model, now use metabase cloud and unfortunately the problem is persisting. I've sent a couple of emails in the last two weeks to arrange a meeting to look at the issue together but I couldn't get any help so far. Is there any chance I could get help from you?