Cannot add click behavior on tables anymore

Hi there, I am new here and also quite new to metabase where I am using version 0.42.4. I created a question with data from a mongoDB which is also shown on a dashboard, since I wanted to use the click behavior to get to another question with detailed data. Therefore I am using the click behavior on one column where I provided the link to another question with the respecitve filters. This worked for a while. However, since I am having metabase running on a cloud plattform and had to move it, I also had to change those urls behind the click behavior. This worked for dashboards where the underlying question is represented by a bar diagramm but not where I use a table. Whenever I want to click on the url to change or define a new click behavior, it exits the editig mode and the current dashboard is displayed without any chosen filter. Am I doing something wrong? To clarify I will note the differen steps I used for created the click behavior:

  1. Open Dashboar and choose data by setting a valid time period (data is shown)
  2. Click on the pencil to make some modification
  3. Click on "Click behavior" on the respective dashboard
  4. Choose the column on which to add a click behavior
  5. Choose the option for click behavior ( I am using the user defined one)
  6. Choose "URL"

Then I would expect that a new pop-up opens where I can enter the url of the question I want to go to, however, it happens what I described above.

Any help is appreciated and if I was to vague in some point, please ask me.
Thank you.

Hi @thirteen
I don't know which version you used before on Cloud, but make sure it's same or newer version.
There's several Click Behavior issues fixed in the past couple of months.
Latest release is 0.43.4: