Cannot connect to Mongo Atlas M2 - Mongodb 4.0

Hi everyone !

We have an instance of the latest version of Metabase (v0.32.2) running on a docker which is connected to M2 Mongo Atlas Cluster (MongoDB 4.0.6 Enterprise) since more than 6 months. We rebooted the docker several times and each time the connection was successful.
As a Metabase database connection if only for one specific database, we decided to add another connection to a new database in the same M2 cluster. With the exact same parameter as the previous connection, except the database name, we cannot succeed in establishing the connection.
From there we tried to redo the connection which is running since 6 months and cannot succeed neither…
Everytime we get the following error:
com.mongodb.MongoTimeoutException: Timed out after 3000 ms while waiting for a server that matches com.mongodb.client.internal.MongoClientDelegate$1@1eba6ab3. Client view of cluster state is {type=REPLICA_SET, servers=[{, type=UNKNOWN, state=CONNECTING, exception={com.mongodb.MongoSocketReadException: Prematurely reached end of stream}}]

We checked these solutions: but not working neither and the bug is closed so it should not be because of this.

Is it a known bug ? Maybe Metabase is not yet compatible with MongoDB 4.0.6 ?
Any solution or help would be perfect !
I can also provide more information if needed


1 Like

Experiencing the same issue, with MongoDB Atlas M20, MongoDB version 4.0.9.

We’ve tried every variation of solution in and nothing seems to work. Would really appreciate some help.

I opened a new issue for this problem.