Cannot get setup_token when deploy in app engine flex & cloud sql postgreSQL

I success to deploy metabase to app engine flex & cloud sql (postgreSQL version: 12).

app.yaml
runtime: custom
service: my-service-name
env: flex

manual_scaling:
  instances: 1

resources:
  cpu: 1
  memory_gb: 1
  disk_size_gb: 10

readiness_check:
  path: "/api/health"
  check_interval_sec: 5
  timeout_sec: 5
  failure_threshold: 2
  success_threshold: 2
  app_start_timeout_sec: 600

beta_settings:
  cloud_sql_instances: lixil-datalake-dev:asia-northeast1:metabase-pgdb=tcp:5432

env_variables:
  MB_DB_DBNAME: 'mydbname'
  MB_DB_TYPE: 'postgres'
  MB_DB_HOST: '172.17.0.1'
  MB_DB_PORT: '5432'
  MB_DB_USER: 'myusername'
  MB_DB_PASS: 'mypass'
  MB_JETTY_PORT: '8080'

Dockerfile:
FROM gcr.io/google-appengine/openjdk

EXPOSE 8080

ENV JAVA_OPTS "-XX:+IgnoreUnrecognizedVMOptions -Dfile.encoding=UTF-8 --add-opens=java.base/java.net=ALL-UNNAMED --add-modules=java.xml.bind"

ENV JAVA_TOOL_OPTIONS "-Xmx1g"

ADD https://downloads.metabase.com/v0.43.0/metabase.jar $APP_DESTINATION

On Welcome to Metabase setup screen, I cannot pass to next screen even I input all information.
On dev tool in networking tab, it seem cannot get setup session token

My app engine have set up IAP but i think this is not a reason.

Please any help for this case, thanks you!

Hi @tanht
The returned error is coming from your reverse-proxy or load-balancer, it's not coming from Metabase.
Check the headers of the request, which might help you understanding what is returning the error.

Thanks you so much for support.
I am not familiar on GCP, my app engine config IAP for all project, how can solved this with IAP in app engine or much be turn off IAP (i tried to turn off IAP but its still error 404).

My header request in below: seem cannot get metabase.SESSION

@tanht I don't know how App Engine functions, but the problem is somewhere there, not in Metabase.
Try searching the forum, here's a configuration example:

1 Like