Cannot setup on AWS in VPC

I’m trying to install Metabase into AWS. We will primarily use it to connect to an RDS database.

I’ve tried about a dozen times with different parameters, but have never successfully booted an instance of Metabase. I’m following the link from the website, and following along in the Elastic Beanstalk configuration guide.

I’d like to install Metabase within our existing VPC. Every time I try, I get an error that says it cannot create the security group: “Stack named ‘awseb-e-jhia37kphv-stack’ aborted operation. Current state: ‘CREATE_FAILED’ Reason: The following resource(s) failed to create: [AWSEBRDSDBSubnetGroup, AWSEBLoadBalancerSecurityGroup].”

I cannot find any more detailed logs anywhere, although it references them.

Does anyone know what’s missing?

For anyone wondering, I did solve this.

The first error (AWSEBRDSDBSubnetGroup) was because RDS instances need to be in a subnets in more than one availability zone (even if you’ve selected “Single AZ” reliability).

The second error (AWSEBLoadBalancerSecurityGroup) is because ELBs cannot be in more than one subnet per availability zone.

The guide says “Best to check all the subnets”, which fixed error one for me but not error two. I had been selecting two subnets in us-east-1a (and nothing else) which failed all of them.


Thanks for sharing

Getting the same thing with the RDS security group. Any ideas?

2018-08-05 17:55:23 UTC-0700 ERROR Creating RDS database security group named: awseb-e-2d4gt563ks-stack-awsebrdsdbsecuritygroup-22q1vfuaib5c failed Reason: Either the resource does not exist, or you do not have the required permissions.

2018-08-05 17:55:23 UTC-0700 ERROR Stack named ‘awseb-e-2d4gt563ks-stack’ aborted operation. Current state: ‘CREATE_FAILED’ Reason: The following resource(s) failed to create: [AWSEBRDSDBSecurityGroup].

Not using RDS nor Elastic Beanstalk myself but StackOverflow seems to be good at answering AWS configuration issues. Even this search limited to what’s tagged Metabase turns up a few that seems relevant here:[metabase]+Amazon-web-services

Let us know how it goes. Might be useful for others! :slight_smile:

I think there might be an issue on AWS’s end, I’m not 100% sure. I spent a lot of time on this, and my friend who works on AWS is also stumped.

I ended up spinning up an EC2 server and running the whole thing there, which is much simpler and worked great first try.