Cannot update binned field: query is missing source-metadata

Following version update joining existing aggregated queries to a new query doesn't work anymore due to bug message:
"Cannot update binned field: query is missing source-metadata".

Share diagnostic info and setup of the queries

Pls find diagnostic info and query setup below:

Case 1 Error msg: query is missing source-metadata
Table with customer information joined via customer ID with supporting table in which I group a count of products sold by customer id, resulting in a table indicating the number of products sold per customer. Column structure: Column 1 - distinct count of product IDs, Column 2 - customer ID

Side note: This setup has worked fine before the version upgrade

Case 2 Error msg: query is missing source-metadata
Joining customer table via customer ID with support table that includes a "case " based categorization per customer based on different attributes, e.g. if budget is x and country is y, set value z. Column structure: Column 1 - customer ID, Column 2 - Categorization

Side note: This setup has worked fine before the version upgrade

  "browser-info": {
    "language": "en",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "19.0.2+7",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "19.0.2",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "19.0.2+7",
    "": "Linux",
    "os.version": "5.15.65+",
    "user.language": "en",
    "user.timezone": "Etc/UTC"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "mysql",
    "application-database-details": {
      "database": {
        "name": "MySQL",
        "version": "5.7.40-google"
      "jdbc-driver": {
        "name": "MariaDB Connector/J",
        "version": "2.7.6"
    "run-mode": "prod",
    "version": {
      "date": "2023-02-19",
      "tag": "v0.45.3",
      "branch": "release-x.45.x",
      "hash": "070f57b"
    "settings": {
      "report-timezone": null

Can you share a screenshot of the GUI or the SQL query you are running? Would be easier to follow

Here you go:
Question 1 with reference to questions 2

Question 2


The issue seems to be related to how the question you are joining loses the metadata and fails when you try to join. The only workaround i can offer for now is to turn that question to a model and update the metadata accordingly. You should be able to perform the join

Quick update here: Unfortunately turning the joined question into a model results in the same error code.

did you try generating the question? Like start form scratch? Can you share the metadata setup as well

No, I turned it into a model from the question. Rebuilding every relevant question that way would be quite inconvenient, so I hope that the bug can be resolved soon in general.

What do you exactly need regarding the metadeta setup? When accessing the model I get the metadata interface with the abilitiy to edit metadata per column.

Update: Problem persists when model is created from scratch.

Was there any update in the meantime regarding a possible upcoming fix?

Should be fixed wit the next release 46.2 Metadata is required when trying join on an SQL based questions · Issue #29795 · metabase/metabase · GitHub