Can't add custom geojson map


I allow myself to post here because I can't add a custom geojson to my self-hosted metabase instance.
Each time I try I got an error about file location.

I use a github rawlink to my geojson and I test it, it's a valid file.

JS console throw me an error 400 and the metabase console show me this error

Does anyone may have an idea about what I do wrong ?
I use the docker version and nginx if that matters.
thanks in advance.

Hi @lamptorne
It says that it cannot lookup the domain, so it sounds like you have some DNS problems in your Docker setup.

@flamber Thank you for the answer.
How could I adress this issue ?
Everything else is working fine including the api, I've just run the docker on port 3000 and using nginx to redirect the domain on it.
I'm out of guesses


Post "Diagnostic Info" from Admin > Troubleshooting.

Are you access the address via the Docker container or via your browser? I'm guessing your browser.
The problem is in the Docker container, which cannot make requests out of the container.
Try this:

docker exec -ti metabase bash
#inside the container

Read more here:

  "browser-info": {
    "language": "fr",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0",
    "vendor": ""
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.15+10",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "11.0.15",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.15+10",
    "": "Linux",
    "os.version": "5.13.0-48-generic",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
    "run-mode": "prod",
    "version": {
      "date": "2022-05-31",
      "tag": "v0.43.2",
      "branch": "release-x.43.x",
      "hash": "433d533"
    "settings": {
      "report-timezone": null

I am trying to acces the url via my webbrowser. I tried to acces inside the container as well with your command but got a bad adress error with ping.

I'm gonna read the documentation you sent

Many thanks for the help.

@lamptorne You should also setup Metabase for production use:

@flamber Thanks for the suggestion I've transferred everything into production.

In the end I use --network host with the container and it's now working fine.
I was able to add the map to my metabase instance.

Many thanks for the quick answers