Can't add SQL Server in Metabase - Timed Out after 10.0s

Hello All!

I'm new to Metabase and trying to gain hands-on. When I tried to add a Local SQL Server DB, I'm getting an error as Timed Out 10.0s

Here are the Configuration Details which I'm using to connect to My Local SQL Server (Local Desktop) with the below details.

Database Type - SQL Server
Name - LocalSysDB
Host - ABC-WS-123
Port -
Database name - master
Database Instance Name - SQLEXPRESS
Username - ABC-WS-123\Shyam (Windows Authentication)
Password - *********

Use a secure connection (SSL)? - No
Additional JDBC connection string options -
Automatically run queries when doing simple filtering and summarizing - Yes
This is a large database, so let me choose when Metabase syncs and scans - No
Periodically refingerprint tables - Yes

Don't know if I'm missing something here.

Hi @ShyamS
Have a look here:
Timeout connecting to SQLEXPRESS [SOLVED]

Thanks, @flamber! Will have it tried and get back for clarifications if any.

Hello, @flamber - Have tried all the methods which were mentioned in the linked thread. Still, No Luck. Any other possible fixes which you can refer to?


  1. Post "Diagnostic Info" from Admin > Troubleshooting.
  2. Which version of MSSQL?
  3. Did you create a port in MSSQL and define the port in Metabase?