Can't configure email (company SMTP) - MailHog works

Hi there,

at first: awesome tool! We will use it for our development team and want to monitor out internal applications with it.
Therefore we need a working email configuration to send out alerts.

Unfortunately I can’t get the email settings to work. I either get the error “Something went wrong. Please try again later” oder “Wrong hostname or port”.

Metabase Version: 0.34.3
Deployed via docker, Postgres as Database (works!)
Added one SQL Server as Datasource (works!)
Access over Web via NGINX Proxy (works!)

Here is what I tried

Company SMTP Settings:
Port: 25
Encryption: STARTTLS

=> does not work! I tried nearly all combinations (Port 465, SSL, TLS, STARTTLS, NONE).

The credentials are correct, I use the same email credentials as our GitLab Instance (which has STARTTLS enabled).

So I setted up a mailhog container via docker on the same machine and linked it to metabase container. It worked out of the box, and an email was sent.
I also tried to configure one of my private email accounts, which has the following options:

User: my@email.address
Port: 465
Encryption: SSL

I have the exact same configuration in my mail client (Apple Mail) and these also don’t work in metabase (same error Something went wrong).

The logs are not producing any output. Sometimes there is an message like SocketException: read timeout, but I don’t know if these are messages from the mail configuration.

I also tried to telnet to our mailserver from inside the container, it worked. So I guess there is no network problem.

At the moment I guess there is a bug in the SSL / TLS / STARTTLS usage of email configuration.

Can anyone help me out? I really want to get the emails going as metabase is such a nice and awesome tool, I want to work with it daily.

Thanks a lot!

Hi @nightcoding
Please post “Diagnostic Info” from Admin > Troubleshooting.
Can you post the error from Admin > Troubleshooting > Logs?
Do you have an antivirus or firewall somewhere that might be intercepting the connection?


Log output as pastebin here:
As the mailserver is within the same network, there is no firewall or antivirus between the metabase instance and the mailserver.

I also tried to send an email from within the container with python, which worked fine. My current solution is as follows:
I’ve installed a postfix relay on the same host as the metabase docker container. This relay accepts mails at port 25 without authentication and sends them through our mailserver. It works.


@nightcoding Are you using the official image or your own custom image?
It’s too difficult to translate everything from German, but I noticed this, when doing a quick look
metabase.plugins.jdbc-proxy Registriere JDBC-Proxy-Treiber für class
Are you using a proxy somewhere - could that be messing with things inside of Java? Since you said it worked from a python script, that doesn’t mean that Java has understood the proxy settings.