Can't Delete Pulse Reports

I am helping a client clean up there Metabase, and for some emails, they still use Pulse reports. I moved them to archive, and discovered that first, archived pulse reports still send emails. Secondly, when I tried to delete the report, I got this error in my console. I used Chrome, then Safari and Firefox to try to delete.

Secondly, I changed the pulse reports to only send to 1 specific email instead of several, but then they still send to the same people.

Is there a way to delete these reports or is the client just going to be stuck with these Pulse reports still sending out?

Hi @schonanderl
I've tried multiple different setups, but when I archive a Pulse, then it stops sending. I can still manually get it to send a mail when clicking the "Send email now", even when it's archived.

Try renaming the pulse, so you are sure you're editing the correct pulse. It can be tricky to figure out when and how pulses are sent.

As for deleting pulses, that API endpoint was removed to prevent problems with the new Subscriptions.
So you're stuck in the in-between transition, where we haven't fully migrated to Subscriptions yet.

Hi @flamber,

Thanks for the response, I did that, but I still got the reports. I discovered the actual root of the problem. When I got the email again, it was from a dashboard subscription, but I go to the actual page of the dashboard and it is one of the ones I deleted. How does one get rid of the phantom emails from deleted dashboards then?

@schonanderl That should not be possible, since 41.2 made it so subscriptions are not sent out for archived dashboards: https://github.com/metabase/metabase/issues/17487

Try unarchiving the dashboard (go to the URL /archive).

Hi flamber, I can't archive them because I deleted them from the archive. Only have the pulses left which I can't delete.

Thanks again for answering my questions.

@schonanderl Since I have absolutely no idea how you could end up in the situation, and also don't know which pulse IDs you are having problems with, then I can only offer trying to loop through all IDs to archive all pulses (or specifically avoid the ones you know should exists).

Remember that the internal "pulse" name covers Pulses, Alerts and Subscriptions.

You can use this in your browser developer console (just replace 1 for each ID you want to archive, and of course change the URL to match yours).

await fetch("https://metabase.example.com/api/pulse/1", {
    "credentials": "include",
    "headers": { "Content-Type": "application/json" },
    "body": "{\"archived\":true}",
    "method": "PUT",
    "mode": "cors"
});

@flamber the issue isn't the pulses. I discovered when going through them. The issue is with dashboards that don't exist anymore, because I deleted them. Still sending out results. Here is a example.

Is there a API for dashboard subscriptions to delete them? That may be the trick.

@schonanderl I understand that, but when I try to reproduce on latest version, then it deletes the Subscription, when I delete a dashboard, since there's a conditional restriction in the database.

It is the same API endpoint for Subscriptions/Pulses/Alerts.
Go to /api/pulse to see all. It should appear with the name "Southeast Dashboard"

@flamber Thanks for the API suggestion, used to query all the dashboards. AS seen, "Southeast Weekly Dashboard" exists. But
Southeast Dashboard
does not exist given that I first archived it and then deleted it. The new dashboard subscriptions work fine, but I clearly can't see in the system the old dashboard, which is still sending the phantom subscriptions. Just to keep context, I also attached the names of the current pulses. "Southeast Weekly Dashboard" appears, which is the new, working dashboard, " Southeast Dashboard" is not present.

@schonanderl You would have to go to Admin > Troubleshooting > Tasks, which will have a task named send-pulse XX, when you receive the email. Then you have the ID of the Pulse and know what to archive.