Can't deploy to Elastic Beanstalk using instructions

Anyone actually get an Elastic Beanstalk instance running with any recent (post log4j) version?

We were unable to deploy a newer version back when Log4J happened so we had to just shutdown our 0.37 instance and go without Metabase since. Recently returned to try and solve the problem again.

Trying to get a brand new Elastic Beanstalk environment running since upgrades don't work for us. I have tried multiple versions (0.42.2, 0.39.7, 0.38.6) and follow the instructions given here ( exactly. The instance never becomes healthy. SSHing to the instance there is a docker image but no running docker processes. There are no metabase logs in the locations mentioned in various StackExchange troubleshooting posts. The docker logs show the image starting and then getting killed but there is zero indication on why it won't start. If I run docker run with the image it starts up correctly or at least claims it is running. It even says it is sending pulses so I assume that means all is good.

I am running a complete vanilla test version here. No external or Beanstalk RDS just letting it make its own DB in a desperate attempt to get anything running. If anyone can follow those instructions and get something running I'd like to hear about it because from what I can tell it isn't possible anymore.

@john_carmichael try sending all the logs to Cloudwatch so you can get some messages about what's going on. By the way, I'm rewriting that entire guide here:, which tells you how to do something simple without any database or how to do every step manually if you need an entire production deployment.

Elastic Beanstalk can be a bit problematic because of what you're mentioning, it tries to abstract the nitty gritty of the technical stuff, but ends up leaving users blind on what's it doing in the middle.

Thanks Luiggi I'll check out the PR you linked.

Should have mentioned, I did configure sending logs to CloudWatch and it creates several log groups but they all remain empty.

@Luiggi That guide was super helpful. I was able to get a basic setup running which allowed me to slowly change settings one at a time to figure out what the issue was. It ended up being a missing IAM permission on our beanstalk roles. Someone was a little too aggressive in their pruning down of overly permissioned roles recently it seems. Thanks so much, I don't know that I ever would have gotten there without your basic setup to at least get a system up and running.