Can't disable MetaBot from UI

Hi All.

We’re trying to disable the MetaBot Slack integration, as it’s not needed and is also filling up the logs with websocket connect errors:

Jul 03 02:24:48 ERROR metabase.metabot.websocket :: Error connecting websocket: connect timed out

From the Admin Interface, under Settings -> Slack, there’s a toggle to disable Metabot.

However, when the toggle is set to “Disabled” and “Save Changes” is clicked, we see a “connect timed out” error, and the change is not persisted (“Enabled” on next page load)

Does saving the “Disabled” setting require a round trip to Slack as well? Because that would fail as well, and explain the situation.

Is there a workaround to disable the integration under the covers? Any ideas?

Cheers, Curtis.

Hi @curtisfox
Which version of Metabase?
How are you running it, docker, jar, …?
Are you using a reverse proxy?
If I remember correctly, it needs to connect to Slack to remove/shutdown the bot there. I don’t have Slack, so not completely sure.

Hi @flamber - Thanks for the quick response!

We’re running v0.32.9, which is the latest I believe.

It’s running in a Docker container behind an ALB.

We’ve just made some port changes to allow the websocket connection to be established, but it looks like the Slack account has been disabled on the Slack end as well.

Saving the Disabled setting now returns “Slack API error: account_inactive” and you still can’t persist the change.

I suppose we can try and reenable the account to complete the process, but I’m still thinking there must be a way to disable the integration more manually, for instance directly in the db.

Thoughts? And thanks again!

Cheers, Curtis.

Okay, AWS LB changes what I think you’re seeing:
But I would guess that you could check the table settings in your metadata database (hoping you’re not using H2) and look for anything slack/metabot.

Thanks @flamber - super useful.

Will have a look and let you know how it goes.