Certicate max length


I am getting an error to authenticate on our SMTP server.
javax.mail.MessagingException: Could not connect to SMTP host: xxxxxxxxxxxxxxx, port: xxx;
nested exception is:
javax.net.ssl.SSLProtocolException: The certificate chain length (11) exceeds the maximum allowed length (10)

I tried running the JVM with -Djdk.tls.maxCertificateChainLength=15, but got no luck.
How can I proceed?

Hi @alexandrebeh
Post "Diagnostic Info" from Admin > Troubleshooting.
I'm guessing that you already read: https://stackoverflow.com/questions/64721644/javax-net-ssl-sslprotocolexception-the-certificate-chain-length-11-exceeds-th

Hello @flamber
Yes, I tried it but the .jar would not start with the parameter
Diagnostic Info:
"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:98.0) Gecko/20100101 Firefox/98.0",
"vendor": ""
"system-info": {
"file.encoding": "Cp1252",
"java.runtime.name": "Java(TM) SE Runtime Environment",
"java.runtime.version": "1.8.0_281-b09",
"java.vendor": "Oracle Corporation",
"java.vendor.url": "http://java.oracle.com/",
"java.version": "1.8.0_281",
"java.vm.name": "Java HotSpot(TM) 64-Bit Server VM",
"java.vm.version": "25.281-b09",
"os.name": "Windows Server 2019",
"os.version": "10.0",
"user.language": "en",
"user.timezone": "America/Sao_Paulo"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
"run-mode": "prod",
"version": {
"tag": "v0.42.2",
"date": "2022-02-28",
"branch": "release-x.42.x",
"hash": "d6ff494"
"settings": {
"report-timezone": "America/Sao_Paulo"


Post the command you used to try to start with.

Upgrade to Java 11:

And migrate away from H2 if you are using Metabase in production: