Chart tooltip and selection showing incorrect values V0.39.3

Hi i have a column(ID) of entity type which has all values greater than 1000, when i try to summarize data with that column, i end up having a graph with x-axis showing me some default date January1,1970 with x-axis in timeseries along with tooltip and i am not able to make any selection due to it.

Tried the same with sampledata database and was able to replicate the issue , below is reference images

Hi @Chetan
Change "X-axis scale" from "Timeseries" to "Ordinal".

Hi @flamber,
Changing x-axis to any other than timeseries resolves the representation issues, but when i try to filter out the result by dragging over the chart somehow the date filters are being applied again and i get the following error, i tried changing the column type to others too but getting same result, although if i have any data in the result less then 1000 then everything works fine.

@Chetan Post "Diagnostic Info" from Admin > Troubleshooting. Looks like you're using a custom build. I cannot reproduce on any official build, since when setting Ordinal, then drag-to-drill is not possible.

I have created an issue for this: - upvote by clicking :+1: on the first post

@flamber, Can you try the same with linear or power or log type?

"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.124 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.11+9-Ubuntu-0ubuntu2.20.04",
"java.vendor": "Ubuntu",
"java.vendor.url": "",
"java.version": "11.0.11",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.11+9-Ubuntu-0ubuntu2.20.04",
"": "Linux",
"os.version": "5.4.72-microsoft-standard-WSL2",
"user.language": "en",
"user.timezone": "Asia/Calcutta"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
"run-mode": "dev",
"version": {
"date": "2021-05-27",
"tag": "v0.39.4-SNAPSHOT",
"branch": "?",
"hash": "598a112"
"settings": {
"report-timezone": null

Thank you

@Chetan Linear works fine.

@flamber Sorry my bad, not the data representation, but the drag-to-drill filter on linear throws the error?


  1. Reproduce with non-custom build
  2. Provide steps to reproduce
  3. Provide errors from Admin > Troubleshooting > Logs, and the browser developer console that are relevant for the problem

@flamber ,
I am happy with the bug which is being raised and I think that covers what I was looking for.
Thanks for the help.