Charts comparision is not working after upgrade (0.37.5)

Hello,

we were using metabase 0.36.6 and the charts comparision ( two reports - charts visualization) is not working…

it worked fine with 0.32.x

we upgraded to 0.37.5 which latest version… still not working

Hi @swarupa
Which version are you using - you say 0.36.6 and then 0.32.x, and that you have upgraded to 0.37.5?
Sounds like the same problem as this closed issue, which seems to be caused by a corrupted question, but I haven’t figured out how to reproduce the problem.
https://github.com/metabase/metabase/issues/13465

Hello flamber,

Thanks for your reply

Now we are at 0.37.5.

It is the similar issue which you provided the bug.

Edit Dashboard
Add Question
Try adding another question to that … it doesnot show up other questions

Regards,
Rupa

@swarupa I understand the problem - I can see that from the screenshots, but I cannot reproduce.
You have to check your log for error - Admin > Troubleshooting > Logs
And check the browser developer Console or Network tab for errors, which might help figuring out where the problem is.

Hi,

Developer Console error

app-main.bundle.js?5a7b474612f375765a87:5 AddSeriesModal loadMetadataForQueries TypeError: Cannot read property 'type' of null
    at Function.value (app-main.bundle.js?5a7b474612f375765a87:5)
    at e.value (app-main.bundle.js?5a7b474612f375765a87:5)
    at app-main.bundle.js?5a7b474612f375765a87:5
    at i (app-main.bundle.js?5a7b474612f375765a87:5)
    at e.n.value (app-main.bundle.js?5a7b474612f375765a87:5)
    at app-main.bundle.js?5a7b474612f375765a87:5
    at Array.map (<anonymous>)
    at t.<anonymous> (app-main.bundle.js?5a7b474612f375765a87:5)
    at l (vendor.bundle.js?5a7b474612f375765a87:98)
    at Generator._invoke (vendor.bundle.js?5a7b474612f375765a87:98)

Hi,

From logs

2021-01-06T20:38:09+01:00 ERROR metabase.models.interface Unable to normalize: 
 {:database 2,
 :type "native",
 :native
 {:query
  " SELECT" }}}}

clojure.lang.ExceptionInfo: Input to normalize-token does not match schema: 

@swarupa Okay, so that’s the problem. You have a question with a broken query. Try looking in your application database table report_card and find the question with dataset_query starting with {"native":{"query":" SELECT" - then go to that question and archive it.

Hello flamber,

is there a way to search that broken question ?

Thanks,
Rupa

@swarupa Only in your application database, since the log doesn’t give enough information as to ID, name or location.

Thank you flamber. I will connect to metabase database and search for that broken query…

Thanks a lot Flamber… It is working fine