Column is not visible in grid view but visible in table view

I have created report where we are showing up data in column format using SQL query.

So client ask us to add 2 more columns, so i added these columns in SQL query but then i do not found newly added columns in my report when i went into table format, i can see that.

I thought it might be related to caching, so i restarted my computer, started it in incognito window but still same problem.

I am not sure what i am missing here.

Hi @manish.joisar
You are likely seeing this issue, which is fixed in the upcoming version 0.40.0
https://github.com/metabase/metabase/issues/15393

Thanks Flamber for your response

When 0.40 is .expected to be released ?

Is there any workaround till that time?

@manish.joisar The workaround is quite technical, so it would be easier if you create a new question instead. That might not be a viable solution for everyone.
I don't know when 0.40.0 will be released - soon.

Thanks Flamber for quick response.

Can you please share the technical workaround, i will see if i can manage with my knowledge.

And yes, you are right, creating a new question will be the last option.

@manish.joisar Open your browser developer Network-tab while saying the question, where you then can see the data being sent during the request. You would then have to remove the table.columns array from the request and resend the request, which would then restore all the column visibility after you refresh the browser.

1 Like

Hello Flamber,

Thanks
You mean, resend the request from PostMan ? using all existing request headers ?

@manish.joisar I mean using your browser, when has an option to resend request, where you then modify the request before sending it. Please just create a new question - it would be a million times easier.

Hello Flamber

In Chrome browser, i didn't found option to resend the request. There was an option to copy it as cURL and all.

I was able to execute the API endpoint without table.columns in request body using Postman and it worked.

Thanks.for your extended help.

@manish.joisar Firefox has this build-in. Wonderful browser :wink:

1 Like

I had the same problem and solved it by changing the column name.

1 Like